In Exchange 2019 but in any version, you cannot mix Exchange versions so they are part of the same DAG. For example, you cannot add an Exchange 2013 server to a 2016 DAG.

I though I would test Exchange 2019 to make sure we don’t have a bug like in Exchange 2016 but it seems they didn’t make that mistake again. As you can see below, I tried to add an Exchange 2019 Server to an Exchange 2016 DAG and it states very clearly you can’t.

Unable to add Exchange-2019 to database availability group TestDAG, because at least one of the current members is a different Exchange Version. Version of Exchange-2016: Version 15.1 (Build 1591.10). Version of Exchange-2019: Version 15.2 (Build 221.12).

Hope it helps.

Advertisements
Advertisements